POJ3258 River Hopscotch(二分)

River Hopscotch
Time Limit: 2000MS

题目链接:
http://poj.org/problem?id=3258
Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance before he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input
Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output
Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source

USACO 2006 December Silver

题目大意:

从0到d中间有一堆石头,她要跳石头的样子,然后她有M次特权可以移走石头,求最大化最小值。

分析:

check函数比较难想啊!!~!

可以看看这个代码块:

bool check(int x)
 {
     int num = n-m;

     int last = 0;
     for(int i=0;i<num;i++)
     {
        int cur = last +1;
            while( cur<=n && a[cur]-a[last]<x)
            {
                cur++;
            }
            if( cur > n)return 0;
            last = cur;
     }
     return 1;
 }

AC代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
#include<string>
using namespace std;
const int maxn=50005;
int d,n,m;
int a[maxn];

bool check(int x)
 {
     int num = n-m;

     int last = 0;
     for(int i=0;i<num;i++)
     {
        int cur = last +1;
            while( cur<=n && a[cur]-a[last]<x)
            {
                cur++;
            }
            if( cur > n)return 0;
            last = cur;
     }
     return 1;
 }

int main()
{
    while(~scanf("%d%d%d",&d,&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        a[n+1]=d;
        sort(a+1,a+n+1);
        int l=0,r=d,ans=0;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(check(mid))l=mid+1,ans=mid;
            else r=mid-1;
        }
        printf("%d\n",ans);
    }
}

这里写图片描述

所以就是ans只会在匹配成功的方向上更新~@@!!
我们就用这个模板吧~~~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值