7-52 两个有序链表序列的交集 (20 point(s))

7-52 两个有序链表序列的交集 (20 point(s))

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的交集新链表S3。

输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:
在一行中输出两个输入序列的交集序列,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。

输入样例:
1 2 5 -1
2 4 5 8 10 -1
输出样例:
2 5

#include <stdio.h>
#include <stdlib.h>

typedef struct _list{
	int data;
	struct _list *next;
}List;

List * Create(void);
List * Combination(List *L1, List *L2);
void Print(List *L3);

int main() {
	List *L1, *L2, *L3;
	L1 = Create();
	L2 = Create();
	L3 = Combination(L1, L2);
	Print(L3);
	return 0;
} 

List * Create(void) {
	List *head, *tail;
	head = (List *)malloc(sizeof(List));
	head->next = NULL;
	tail = head;
	int num;
	while (scanf("%d", &num) == 1 && num != -1) {
		List *p = (List *)malloc(sizeof(List));
		p->data = num;
		tail->next = p;
		tail = p;
	}
	tail->next = NULL;
	return head;
} 

List * Combination(List *L1, List *L2) {
	List *head, *tail;
	head = (List *)malloc(sizeof(List));
	head->next = NULL;
	tail = head;
	while (L1->next && L2->next) {
		if (L1->next->data > L2->next->data) {
			L2->next = L2->next->next;
		}
		else if (L1->next->data < L2->next->data){
			L1->next = L1->next->next;
		}
		else {
			tail->next = L1->next;
			tail = tail->next;
			L1->next = L1->next->next;
			L2->next = L2->next->next;
		}
	}
	return head;
}

void Print(List *L3) {
	if (L3->next) {
		while (L3->next) {
			printf("%d", L3->next->data);
			if (L3->next->next) {
				printf(" ");
			}
			else {
				printf("\n");
			}
			L3 = L3->next;
		}
	}
	else {
		printf("NULL");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值