7-51 两个有序链表序列的合并 (20 point(s))

7-51 两个有序链表序列的合并 (20 point(s))

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。

输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。

输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL。

输入样例:
1 3 5 -1
2 4 6 8 10 -1
输出样例:
1 2 3 4 5 6 8 10

#include <stdio.h>
#include <stdlib.h>

typedef struct _list{
	int data;
	struct _list *next;
}List;

List * Create(void);
List * Combination(List *L1, List *L2);
void Print(List *L3);

int main() {
	List *L1, *L2, *L3;
	L1 = Create();
	L2 = Create();
	L3 = Combination(L1, L2);
	Print(L3);
	return 0;
} 

List * Create(void) {
	List *head, *tail;
	head = (List *)malloc(sizeof(List));
	head->next = NULL;
	tail = head;
	int num;
	while (scanf("%d", &num) == 1 && num != -1) {
		List *p = (List *)malloc(sizeof(List));
		p->data = num;
		tail->next = p;
		tail = p;
	}
	tail->next = NULL;
	return head;
} 

List * Combination(List *L1, List *L2) {
	List *head, *tail;
	head = (List *)malloc(sizeof(List));
	head->next = NULL;
	tail = head;
	while (L1->next && L2->next) {
		if (L1->next->data >= L2->next->data) {
			tail->next = L2->next;
			L2->next = L2->next->next;
		}
		else {
			tail->next = L1->next;
			L1->next = L1->next->next;
		}
		tail = tail->next;
	}
	tail->next = L1->next ? L1->next : L2->next;
	return head;
}

void Print(List *L3) {
	if (L3->next) {
		while (L3->next) {
			printf("%d", L3->next->data);
			if (L3->next->next) {
				printf(" ");
			}
			else {
				printf("\n");
			}
			L3 = L3->next;
		}
	}
	else {
		printf("NULL");
	}
}
以下是使用C语言实现合并两个有序链表序列的代码: ```c #include <stdio.h> #include <stdlib.h> // 定义链表结构体 typedef struct Node { int value; // 值 struct Node *next; // 指向下一个节点的指针 } Node; // 合并两个有序链表 Node *mergeLists(Node *list1, Node *list2) { Node *head = NULL; // 合并链表的头节点 Node *tail = NULL; // 合并链表的尾节点 // 如果有一个链表为空,则直接返回另一个链表 if (list1 == NULL) { return list2; } else if (list2 == NULL) { return list1; } // 选择头节点 if (list1->value < list2->value) { head = list1; list1 = list1->next; } else { head = list2; list2 = list2->next; } tail = head; // 循环合并两个链表 while (list1 != NULL && list2 != NULL) { if (list1->value < list2->value) { tail->next = list1; list1 = list1->next; } else { tail->next = list2; list2 = list2->next; } tail = tail->next; } // 将剩余的节点添加到尾部 if (list1 != NULL) { tail->next = list1; } else { tail->next = list2; } return head; } // 打印链表 void printList(Node *list) { while (list != NULL) { printf("%d ", list->value); list = list->next; } printf("\n"); } int main() { // 创建两个有序链表 Node *list1 = (Node *) malloc(sizeof(Node)); list1->value = 1; list1->next = (Node *) malloc(sizeof(Node)); list1->next->value = 3; list1->next->next = (Node *) malloc(sizeof(Node)); list1->next->next->value = 5; list1->next->next->next = NULL; Node *list2 = (Node *) malloc(sizeof(Node)); list2->value = 2; list2->next = (Node *) malloc(sizeof(Node)); list2->next->value = 4; list2->next->next = (Node *) malloc(sizeof(Node)); list2->next->next->value = 6; list2->next->next->next = NULL; // 合并两个有序链表 Node *mergedList = mergeLists(list1, list2); // 打印合并后的链表 printList(mergedList); return 0; } ``` 输出结果为: ``` 1 2 3 4 5 6 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值