Squares POJ2002 哈希的应用

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 
Input
The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output
For each test case, print on a line the number of squares one can form from the given stars.
Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0
Sample Output
1
6
1


题意:

有一堆平面散点集,任取四个点,求能组成正方形的不同组合方式有多少。

相同的四个点,不同顺序构成的正方形视为同一正方形。


思路:

暴力枚举四个点肯定超时, pass

先枚举两个点, 然后再(乱搞)计算出另外两个点的坐标, 在哈希表中查找是否存在这两个坐标(存在就代表可以画出一个正方形)。因为每条边都计算了一次, 所以最后结果除以4。 


大家可以先推推两外两个点的坐标, 下面给出结果:

已知: (x1,y1)  (x2,y2)

则:   

x3 = x1 + (y1-y2)   y3 = y1 - (x1-x2)   x4 = x2 + (y1-y2)   y4 = y2 -(x1-x2)

x3 = x1 - (y1-y2)   y3 = y1 + (x1-x2)  x4 = x2 - (y1-y2)   y4 = y2 + (x1-x2)


其实还可以 已知一条对角线上两个点的坐标, 计算出另外两个点的坐标。 结果就不写了, 大家可以去推推


哈希表用数组模拟链表。 具体看代码

AC code: 1125ms

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

struct  Node{
    int x, y, next;
}Hash[1200];
int cur, ans, hashTable[10011];

void init() {
    cur = ans = 0;
    memset(hashTable, -1, sizeof(hashTable));
}

void insert(int x, int y) {
    int number = (x*x + y*y) % 10011;
    Hash[cur].x = x;
    Hash[cur].y = y;
    Hash[cur].next = hashTable[number];
    hashTable[number] = cur;
    cur++;
}

bool search(int x, int y) {
    int number = (x*x + y*y) % 10011;
    int next = hashTable[number];
    while (next != -1) {
        if (Hash[next].x == x && Hash[next].y == y) return true;
        next = Hash[next].next;
    }
    return false;
}

int main(void) {
    int n;
    while (cin >> n , n) {
        init();
        int x[1200], y[1200];
        for (int i = 0; i < n; i++) {
            cin >> x[i] >> y[i];
            insert(x[i], y[i]);
        }
        
        for (int i = 0; i < n; i++) {
            for (int j = i+1; j < n; j++) {
                int x1 = x[i] - y[i] + y[j], y1 = y[i] + x[i] - x[j];
                int x2 = x[j] - y[i] + y[j], y2 = y[j] + x[i] - x[j];
                if (search(x1, y1) && search(x2, y2)) ans++;
                int x3 = x[i] + y[i] - y[j], y3 = y[i] - x[i] + x[j];
                int x4 = x[j] + y[i] - y[j], y4 = y[j] - x[i] + x[j];
                if (search(x3, y3) && search(x4, y4)) ans++;
            }
        }
        
        cout << ans/4 << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值