20160811多校:(hdu5821 Ball)【贪心+排序】

题意:T组数据,每组给定一个n一个m,在给定两个长度为n的数组a和b,再给定m次操作,每次给定l和r,每次可以把[l,r]的数进行任意调换位置,问能否在转换后使得a数组变成b数组。

分析:n,m的数据范围只有1000,所以可以考虑O(n^2),也就是贪心做

            首先,贪心找出 每个球最后对应的位置(越前面的匹配越前面),用一个结构体a,存a数组的值和最后匹配的位置

            其次,对于m行中,对每个在区间[l,r]的结构体a进行排序。

            最后,看每个值是否一一对应

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 94    Accepted Submission(s): 52


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct elem
{
	int num;
	int pos;
} a[2005];
int b[2005];
int vis[2005];
bool cmp(elem x,elem y)
{
	return x.pos<y.pos;
}
int main()
{
	int n,m;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		int i;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i].num);
		}
		for(i=1;i<=n;i++) scanf("%d",&b[i]);
		int j,f1=0;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(a[i].num==b[j]&&!vis[j])
				{
					a[i].pos=j;vis[j]=1;break;
				}
			}
			if(j==n+1) {
				f1=1;break;
			}
		}
		int l,r;
		while(m--)
		{
			scanf("%d%d",&l,&r);
			sort(a+l,a+r+1,cmp);
		}
		int f2=0;
		for(i=1;i<=n;i++)
		{
			if(a[i].num!=b[i]){
				f2=1;break;
			}
		}
		if(f1||f2) printf("No\n");
		else printf("Yes\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值