PAT (Advanced Level) 1005. Spell It Right (20)

1005. Spell It Right (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

这道题刚开始没有仔细看,以为很简单,后来发现有两个测试点过不去,,才发现,原来位数digit是10的100次方级别(最大的)所以,如果按照原始的判断不超过三位是错误的。。。

这里我还是用了stack来倒一下结果。。。然后用了vector,没有用string,string应该也可以,,但是还是不熟悉~

刚开始还把除和取余数搞混了,,然后就是size()要减1,最后stack()输出注意一下就ok了~

#include<cstdio>
#include<string.h>
#include<vector>
#include<string>
#include<stack>
#include<algorithm>

using namespace std;
const int maxn = 1000000000;

char s[10][10] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
//char a[maxn];
vector<char> a;
stack<int> rr;

int main() {
	long long ans = 0;
	char temp;
	while (scanf("%c", &temp) && temp!= '\n') {
		a.push_back(temp);
	}
	a.push_back('\0');
	
	for (int i = 0; i < a.size()-1; i++) {
		//printf("size: %d\n", a.size());
		ans += a[i] - '0';
	}
	
	while (ans / 10 != 0) {
		rr.push(ans % 10);
		//printf("%s ", s[ans % 10]);
		ans /= 10;
	}
	rr.push(ans);

	while(!rr.empty()) {
		int r;
		r = rr.top();
		rr.pop();
		printf("%s", s[r]);
		if (!rr.empty()) {
			printf(" ");
		}
		else {
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值