大数加法

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
    
2
1  2
112233445566778899 998877665544332211
 

Sample Output
 
    
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
    第一次写博客就来个大数加法,可真是费了一番功夫,但无非就是模拟数学加法列竖式计算。
    先用字符数组把两个加数当作字符串接收,再从最低位开始相加赋值到另一字符数组里(其实可以将较短的字符串与较长的 字符串从最低位相加赋值到较长的字符串里),满十向前进一位。
    不多说了,上代码自行体会。
示例代码:

#include <iostream>
#include <cstdio>
#include <cstring>
typedef long long ll;
using namespace std;
int main()
{
    char a[1020],b[1020],c[1020];
    int n,No=1;
    scanf("%d",&n);
    while(n--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        scanf("%s %s",a,b);
        int l1=strlen(a);
        int l2=strlen(b);
        int t=0;
        while(l1>0&&l2>0)
        {
            c[t]+=a[--l1]-'0'+b[--l2]-'0';
            if(c[t]>=10)
            {
                c[t+1]+=c[t]/10;
                c[t]%=10;
            }
            t++;
        }
        while(l1>0||l2>0)
        {
            if(l1==0&&l2!=0)
            {
                c[t]+=b[--l2]-'0';
                if(c[t]>=10)
                {
                    c[t+1]+=c[t]/10;
                    c[t]%=10;
                }
            }
            else if(l1!=0&&l2==0)
            {
                c[t]+=a[--l1]-'0';
                if(c[t]>=10)
                {
                    c[t+1]+=c[t]/10;
                    c[t]%=10;
                }
            }
            t++;
        }
        printf("Case %d:\n",No++);
        printf("%s + %s = ",a,b);
        for(int i=t;i>=0;i--)
        {
            if(i==t&&c[i]!=0)
                putchar(c[i]+'0');
            if(i!=t)
            putchar(c[i]+'0');
        }
        printf("\n");
        if(n!=0)printf("\n");
    }
    return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值