POJ 1328 Radar Installation (贪心)

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1



题意:给出岛的个数n和雷达能够覆盖的最大半径d。再给出n个岛的坐标信息,问最少需要多少个雷达能够覆盖n个岛。


解题思路:

根据每个岛的坐标来计算能够覆盖该岛的雷达在x轴上的区间。将所有区间都保存下来后,从第一个区间开始往后遍历,如果下一个岛的左区间端点left大于这个岛的右区间端点right则需要一个新的雷达即sum++。


使用结构体数组来保存每个岛的信息,需要保存四个变量:岛的横纵坐标,能够覆盖该岛的左区间端点以及右区间端点。

以每个岛的坐标计算出能够覆盖该岛的区间保存在对应的点的信息中。


还应注意如果至少有一个岛不能被覆盖则应输出-1


AC代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;

struct node
{
	double x,y,left,right;
} p[1010];

bool cmp(node a,node b)
{
	return a.right<b.right;
}

int main()
{
	int n,r,tt=1;
	while(~scanf("%d%d",&n,&r))
	{
		if(n==0&&r==0) break;
		int flag=1;
		if(r<0) flag=0;
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&p[i].x,&p[i].y);
			double dis=r*r-p[i].y*p[i].y;
			if(dis<0) {flag=0;continue;}
			p[i].left=p[i].x-sqrt(dis);
			p[i].right=p[i].x+sqrt(dis);
		}
		if(flag==0)
		{
			printf("Case %d: -1\n",tt++);
			continue;
		}
		sort(p,p+n,cmp);
		int sum=0;
		double temp=p[0].right;
		for(int i=1;i<n;i++)
		{
			if(p[i].left>temp)
			{
				sum++;
				temp=p[i].right;
			}
		}
		printf("Case %d: %d\n",tt++,sum+1);
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值