HDU1258/POJ1564 Sum It Up(DFS)

这都是一道题。。。Orz



Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general. 
InputThe input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions. 
OutputFor each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice. 
Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25



题意:给出m,n以及n个数,n个数按照非递减顺序排列(可能有重复的元素),让你在n个数中选cnt个数,找出所有满足cnt个数的和等于m的情况。找不到就输出NONE


解题思路:DFS

从第一个数组元素开始往后搜索,如果满足sum<=m则一直搜索下去,递归边界就是找到了sum==m,找到一个输出一个。

因为给出的顺序已经是按照非递减顺序排列了,所以就不必再重新排序了。但要注意的是给出的元素可能会有重复的,所以在搜索的时候要考虑跳过重复的元素,这里是采用把下标往后挪的方式来实现的(即i++)。


AC代码:


#include<stdio.h>

int a[15],t[15],flag,n,m;

void dfs(int x,int sum,int cnt)//x表示下标,sum累加和,cnt当前累加了多少个数(方便输出)
{
	if(sum>m) return;
	if(sum==m)
	{
		flag=1;
		for(int i=0;i<cnt;i++)
		{
			printf("%d",t[i]);
			if(i<cnt-1) printf("+");
			else printf("\n");
		}
		return;
	}
	for(int i=x;i<n;i++)
	{
		if(sum+a[i]<=m)
		{
			t[cnt]=a[i];
			dfs(i+1,sum+a[i],cnt+1);	
		}
		while(a[i]==a[i+1]&&i+1<n)//跳过重复元素,避免结果和以前搜到的结果一样
				i++;
	}
}

int main()
{
	while(~scanf("%d%d",&m,&n)&&n)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		printf("Sums of %d:\n",m);
		flag=0;
		dfs(0,0,0);
		if(flag==0) printf("NONE\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值