The 15th Zhejiang Provincial Collegiate Programming Contest Sponsored L Doki Doki Literat(结构体排序)

142 篇文章 3 订阅

Doki Doki Literature Club

Time Limit: 1 Second       Memory Limit: 65536 KB

Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!

A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

The poem writing mini-game (from wikipedia)

BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of  words  is nothing more than a sequence of  strings, and the happiness of Sayori after reading the poem is calculated by the formula

where   is the happiness and   is Sayori's preference to the word  .

Given a list of  words and Sayori's preference to each word, please help BaoBao select  words from the list and finish the poem with these  words to maximize the happiness of Sayori.

Please note that each word can be used at most once!

Input

There are multiple test cases. The first line of input contains an integer  (about 100), indicating the number of test cases. For each test case:

The first line contains two integers  and  (), indicating the number of words and the length of the poem.

For the following  lines, the -th line contains a string consisting of lowercased English letters  () and an integer  (), indicating the -th word and Sayori's preference to this word. It's guaranteed that  for all .

Output

For each test case output one line containing an integer  and  strings  separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the lexicographically smallest one.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

sequence of  strings  is lexicographically smaller than another sequence of  strings , if there exists a  () such that  for all  and  is lexicographically smaller than .

string  is lexicographically smaller than another string , if there exists a  () such that  for all  and , or  for all  and .

Sample Input
4
10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200
5 5
collegiate 0
programming -5
zhejiang 10
provincial 5
contest -45
3 2
bcda 1
bcd 1
bbbbb 1
3 2
a 1
aa 1
aaa 1
Sample Output
2018 if winter comes can spring be far behind
15 zhejiang provincial collegiate programming contest
3 bbbbb bcd
3 a aa


题目链接:Doki Doki Literature Club


题意:给出n,m。有n个单词,每个单词后是对应的happy值f[i],我们要选出m个单词(做成一首诗)使得所得到的happy值H最大,H与每个f[i]的关系如题中的公式。

拿Case1解释一下:

10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200

10个单词里选出8个使得happy值最大。我们得到200*8+25*7+20*6+15*5+10*4+2*3+1*2+0*1=2018

所谓的公式也就是把happy值乘以对应的下标,下标从m开始到1。

还要注意多种情况时按字典序输出最小的。

解题思路:

结构体对happy值从大到小和单词按字典序从小到大进行排序,直接选取前m个计算并输出即可。


AC代码:

#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;

struct node
{
	char str[20];
	long long x;
} q[110];

int cmp(node a,node b)
{
	if(a.x==b.x)
	{
		if(strcmp(a.str,b.str)<0) return 1;
		else return 0;
	}
	return a.x>b.x;
}

int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		{
			scanf("%s%lld",q[i].str,&q[i].x);
		}
		sort(q+1,q+n+1,cmp);
		
//		printf("********\n");
//		for(int i=1;i<=n;i++)
//		{
//			printf("%s %d\n",q[i].str,q[i].x);
//		}
		
		long long sum=0;
		for(int i=m,j=1;i>=1;i--,j++)
		{
			sum+=q[j].x*i;
			//printf("q[%d]===%d sum===%lld\n",j,q[j].x,sum);
		}
		printf("%lld ",sum);
		
		int flag=0;
		for(int i=1;i<=m;i++)
		{
			if(flag) printf(" ");
			printf("%s",q[i].str);
			flag=1;
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值