杭电1212 Big Number (大数求模运算)

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5846 Accepted Submission(s): 4086

Problem Description

As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

Output

For each test case, you have to ouput the result of A mod B.

Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521

Author
Ignatius.L

Source
杭电ACM省赛集训队选拔赛之热身赛

解题思想:
这道题是关于大数求模,算法思想在于:

abc%m=(a*100+b*10+c)%m
            =(a*100%m+b*10%m+c%m)%m

所以我们可以先求出10^1………10^Length of A 对m的求模结果,保存到N[1001]数组中。
然后,从个位开始分别按照公式求模,如果和大于m,再对和进行去模,一直循环下去可以得到结果。

代码如下:

#include<stdio.h>
#include<iostream>
using namespace std;
int N[1001];
char str[1001];
int main()
{
    int m,num=1,res;
    while(cin>>str>>m)
    {
        int len=strlen(str)-1;
        res=0;
        for(int i=0;i<=len;i++)
        {
          int x=str[len-i]-'0';
          num*=10;
          num%=m;
          if(i==0) num=1;
          N[i]=num;
          res+=x*N[i];
          if(res>m) res%=m; 
        }
        cout<<res<<endl;
    }
    return 0;
}

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1212

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值