POJ 2301 && HDU 1194 Beat the Spread!(水~)

562 篇文章 1 订阅
470 篇文章 3 订阅

Description
解方程 x=a+b,y=a-b,求a b
Input
第一行为用例组数,每组用例包括两个整数x,y
Output
对于每组用例,输出解a,b,若不存在可行解则输出impossible
Sample Input
2
40 20
20 40
Sample Output
30 10
impossible
Solution
水题,注意a>=b
Code

#include<stdio.h>
int main()
{
    int a,b,n;
    scanf("%d",&n);
    while(n)
    {
        scanf("%d%d",&a,&b);
        if(a<b||(a+b)%2!=0)
            printf("impossible\n");
        else
            printf("%d %d\n",(a+b)/2,(a-b)/2);
        n--;
    }
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值