Description
迈克尔开车去逛商场,每个商场前都有一个停车场,现在迈克尔要去n个商场买东西,问车停在哪个商场使得迈克尔步行路程最短
Input
第一行为用例组数t,每组用例第一行为商场个数n,第二行为n个商场的位置
Output
对于每组用例,输出迈克尔步行最短路程
Sample Input
2
4
24 13 89 37
6
7 30 41 14 39 42
Sample Output
152
70
Solution
水题,令p[i]表示第i个商场的位置,则ans=2*(max{p[i]}-min{p[i]})
Code
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int p[30];
int main()
{
int T,n;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&p[i]);
sort(p,p+n);
printf("%d\n",2*(p[n-1]-p[0]));
}
return 0;
}