POJ 3903 Stock Exchange(LIS)

17 篇文章 0 订阅

Description
给出一长度为n的序列,问其最长上升子序列长度
Input
多组输入,每组用例第一行为序列长度n,第二行n个整数表示该序列,以文件尾结束输入
Output
对于每组用例,输出最长上升子序列长度
Sample Input
6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1
Sample Output
3
1
1
Solution
LIS裸题,套模版即可
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<string>
using namespace std;
#define maxn 111111
#define INF 1<<29
int dp[maxn],n,a[maxn];//dp[i]表示以第i个元素结尾的最长上升子序列,n表示序列长度 
int get_lower_bound(int x)
{
    int l=0,r=n-1;
    while(l<=r)
    {
        int mid=(l+r)>>1;
        if(dp[mid]>=x)
            r=mid-1;
        else
            l=mid+1;
    }
    return l;
}
int LIS(int a[])//求序列a的最长上升子序列 
{
    for(int i=0;i<n;i++)
        dp[i]=INF;
    for(int i=0;i<n;i++)
        dp[get_lower_bound(a[i])]=a[i];
    return get_lower_bound(INF);
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        printf("%d\n",LIS(a));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值