CodeForces 622 B. The Time(水~)

Description
给出一个时刻,输出a s后的时刻
Input
首先是hh:mm的格式表示时刻(0<=hh<=23,0<=mm<=59),之后是一个时间间隔a(0<=a<=10^4)
Output
输出a s后的时刻
Sample Input
23:59
10
Sample Output
00:09
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int h,m,a,res;
    while(~scanf("%d:%d%d",&h,&m,&a))
    {
        res=(h*60+m+a)%1440;
        printf("%02d:%02d\n",res/60,res%60);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值