Description
给出一个时刻,输出a s后的时刻
Input
首先是hh:mm的格式表示时刻(0<=hh<=23,0<=mm<=59),之后是一个时间间隔a(0<=a<=10^4)
Output
输出a s后的时刻
Sample Input
23:59
10
Sample Output
00:09
Solution
水题
Code
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int h,m,a,res;
while(~scanf("%d:%d%d",&h,&m,&a))
{
res=(h*60+m+a)%1440;
printf("%02d:%02d\n",res/60,res%60);
}
return 0;
}