CodeForces 616 B. Dinner with Emma(水~)

Description
给出一个n*m矩阵,找出行元素最小值中的最大值
Input
第一行两个整数n和m表示矩阵行列数,之后一个n*m矩阵c(1<=n,m<=100,1<=c[i][j]<=10^9)
Output
输出这个矩阵行元素最小值中的最大值
Sample Input
3 4
4 1 3 5
2 2 2 2
5 4 5 1
Sample Output
2
Solution
水题
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define INF 0x7f7f7f7f7f
int n,m;
ll c,temp,ans; 
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        ans=0;
        for(int i=1;i<=n;i++)
        {
            temp=INF;
            for(int j=1;j<=m;j++)
            {
                scanf("%I64d",&c);
                temp=min(temp,c);
            }
            ans=max(ans,temp);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值