CodeForces 697 A. Pineapple Incident(水~)

Description
给出两个整数s,t,由s和t形成一个序列 t, t + s, t + s + 1, t + 2s, t + 2s + 1, …,t+ks,t+ks+1,…,问整数x是否属于这个序列
Input
三个整数t,s,x(0<=t,x<=10^9,2<=s<=10^9)
Output
如果x在这个序列中则输出YES,否则输出NO
Sample Input
3 10 4
Sample Output
NO
Solution
水题
Code

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
int main()
{
    ll t,s,x;
    while(~scanf("%I64d%I64d%I64d",&t,&s,&x))
    {
        if(x==t||x>t&&(x-t)%s==0||x>t+1&&(x-t-1)%s==0)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值