Description
给出n个整点,问这n个点能够形成多少个不同的锐角三角形
Input
多组用例,每组用例首先输入一个整数n表示点数,之后n行每行两个整数x和y表示该点坐标,以文件尾结束输入(3<=n<=2000,0<=x,y<=10^9)
Output
对于每组用例,输出这n个点能够形成的锐角三角形个数
Sample Input
3
1 1
2 2
2 3
3
1 1
2 3
3 2
4
1 1
3 1
4 1
2 3
Sample Output
0
1
2
Solution
n个点构成C(n,3)个三角形,设钝角和直角的个数为x和y,三点共线情况数为cnt,那么答案就是C(n,3)-x-y-cnt
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
#define maxn 2222
struct Point
{
ll x,y;
Point(){}
Point(ll _x,ll _y)
{
x=_x;y=_y;
}
Point operator -(const Point &b)const
{
return Point(x-b.x,y-b.y);
}
ll operator ^(const Point &b)const
{
return x*b.y-y*b.x;
}
ll operator *(const Point &b)const
{
return x*b.x+y*b.y;
}
bool operator<(const Point &b)const
{
int f1=0,f2=0;
if(y>0||y==0&&x>=0)f1=1;
if(b.y>0||b.y==0&&b.x>=0)f2=1;
if(f1^f2)return f1;
if(x*b.y-y*b.x!=0)return x*b.y-y*b.x>0;
return x*x+y*y<b.x*b.x;
}
}a[maxn],v[2*maxn];
int n;
int main()
{
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)scanf("%d%d",&a[i].x,&a[i].y);
ll ans=1ll*n*(n-1)*(n-2)/6,cnt=0;
for(int i=1;i<=n;i++)
{
int tot=0;
for(int j=1;j<=n;j++)
if(i!=j)v[tot++]=a[j]-a[i];
sort(v,v+tot);
//for(int i=0;i<tot;i++)printf("%d %d\n",v[i].x,v[i].y);
for(int j=0;j<tot;j++)v[tot+j]=v[j];
ll temp=0;
for(int j=0;j<tot-1;)
{
if((v[j]^v[j+1])==0&&v[j]*v[j+1]>0)
{
temp=1;
while(j<tot-1&&(v[j]^v[j+1])==0&&v[j]*v[j+1]>0)j++,temp++;
cnt+=temp*(temp-1)/2;
}
else j++;
}
for(int j=0,p1=0,p2=0;j<tot;j++)
{
while(p1<=j||p1<j+tot&&(v[p1]^v[j])<0&&v[p1]*v[j]>0)p1++;
while(p2<=j||p2<j+tot&&(v[p2]^v[j])<0)p2++;
ans-=p2-p1;
}
}
printf("%I64d\n",ans-cnt/2);//cnt除以2是因为一种共线情况被算了两次
}
return 0;
}