GYM 100030 K.Triskaidekaphobia(水~)

253 篇文章 2 订阅

Description
一个只有1和3的数字串,要求去掉最少的数字使得该串中不出现13
Input
一个只有1和3的数字串,长度不超过1000
Output
输出要使得整个串不出现13所需删去的最少数字
Sample Input
313
Sample Output
1
Solution
最后的合法串一定是3……31……1,那么枚举这个3和1的临界点,统计前面1的数量和后面3的数量表示要删的数字,更新最小值即为答案
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 1111
char s[maxn];
int a[maxn],b[maxn];
int main()
{
    freopen("input.txt","r",stdin);
    freopen("output.txt","w",stdout);
    while(~scanf("%s",s))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        int n=strlen(s);
        a[0]=(s[0]=='1');
        b[n-1]=(s[n-1]=='3');
        for(int i=1;i<n;i++)a[i]=a[i-1]+(s[i]=='1');
        for(int i=n-2;i>=0;i--)b[i]=b[i+1]+(s[i]=='3');
        int ans=b[0];
        for(int i=0;i<n;i++)ans=min(ans,a[i]+b[i+1]);
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值