CodeForces 621 D.Rat Kwesh and Cheese(水~)

Description
给出三个实数x,y,z,问以下十二个值中哪个最大
这里写图片描述
Input
三个实数x,y,z(0.1<=x,y,z<=200.0)
Output
输出12种形式中值最大的一种形式
Sample Input
1.1 3.4 2.5
Sample Output
z^y^x
Solution
取个对数拿long double怼
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long double ld;
ld x,y,z,ans[13];
void deal(ld x,ld y,ld z,int a)
{
    ans[a+1]=pow(y,z)*log(x);
    ans[a+2]=pow(z,y)*log(x);
    ans[a+3]=ans[a+4]=y*z*log(x);
}
void output(char x,char y,char z,int a)
{
    if(a==1)printf("%c^%c^%c\n",x,y,z);
    else if(a==2)printf("%c^%c^%c\n",x,z,y);
    else if(a==3)printf("(%c^%c)^%c\n",x,y,z);
    else printf("(%c^%c)^%c\n",x,z,y);
}
int main()
{
    double x,y,z;
    while(cin>>x>>y>>z)
    {
        deal(x,y,z,0);
        deal(y,x,z,4);
        deal(z,x,y,8);
        int pos=1;
        for(int i=2;i<=12;i++)
            if(ans[i]>ans[pos])pos=i;
        if(pos<=4)output('x','y','z',pos);
        else if(pos<=8)output('y','x','z',pos-4);
        else output('z','x','y',pos-8);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值