CodeForces 637 B.Chat Order(水~)

Description
有一堆人的申请,先来的人在下面,一个人可能交了很多次申请,现在从下往上开始处理,如果一个人之前已经处理过就不处理了,问处理的顺序
Input
第一行一整数n表示申请的数量,之后n个串长不超过10的串表示每次申请的人(1<=n<=2e5)
Output
输出处理的顺序
Sample Input
4
alex
ivan
roman
ivan
Sample Output
ivan
roman
alex
Solution
倒着输出,之前输出了就不输出了,拿map存一下已经输出的人名即可
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 222222
int n;
map<string,int>m;
string s[maxn];
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)cin>>s[i];
        m.clear();
        for(int i=n;i>=1;i--)
            if(m[s[i]])continue;
            else m[s[i]]=1,cout<<s[i]<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值