CodeForces 396 B.On Sum of Fractions(数论)

Description
定义v(n)为不大于n的最大素数,u(n)为大于n的最小素数,求这里写图片描述
Input
第一行一整数T表示用例组数,每组用例输入一整数n(T<=500,2<=n<=1e9)
Output
输出答案的最简分数表示
Sample Input
2
2
3
Sample Output
1/6
7/30
Solution
这里写图片描述
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 111111
bool check(int n)
{
    for(int i=2;i*i<=n;i++)
        if(n%i==0)return 0;
    return 1;
}
ll gcd(ll a,ll b)
{
    return b?gcd(b,a%b):a;
}
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int p=n,q=n+1;
        while(!check(p))p--;
        while(!check(q))q++;
        ll a=1ll*p*q+2ll*(n-p-q)+2,b=2ll*p*q;
        ll g=gcd(a,b);
        printf("%I64d/%I64d\n",a/g,b/g);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值