CodeForces 835 A.Key races(水~)

Description
两个人进行打字比赛,第一个人速度为v1,延时为t1,第二个人速度为v2,延时为t2,有s个字,收到要打的文本算一次延时,提交答案算一次延时,问谁更快
Input
五个整数s,v1,t1,v2,t2(1<=s,v1,t1,v2,t2<=1000)
Output
如果第一个人更快则输出First,如果第二个人更快则输出Second,如果一样快则输出Friendship
Sample Input
5 1 2 1 2
Sample Output
First
Solution
算出s*v1+2*t1和s*v2+2*t2比一下谁用时更短即可
Code


#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int s,v1,v2,t1,t2;
    while(~scanf("%d%d%d%d%d",&s,&v1,&v2,&t1,&t2))
    {
        int x=v1*s+2*t1,y=v2*s+2*t2;
        if(x<y)printf("First\n");
        else if(x>y)printf("Second\n");
        else printf("Friendship\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值