CodeForces 116 A.Tram(水~)

Description

给出一个会场n次进场出场情况,问会场中人数最大值

Input

第一行一个整数n表示进出场次数,之后n行每行输入两个整数 ai,bi 表示有 ai 个人出场,有 bi 个人进场 (2n2000,0ai,bi1000)

Output

输出会场中人数最大值

Sample Input

4
0 3
2 5
4 2
4 0

Sample Output

6

Solution

水题,开一个变量维护会场中人数然后取个最大值即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int n,a,b;
int main()
{
    while(~scanf("%d",&n))
    {
        int num=0,Max=0;
        while(n--)
        {
            scanf("%d%d",&a,&b);
            num=num-a+b;
            Max=max(Max,num);
        }
        printf("%d\n",Max);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值