CodeForces 263 A.Beautiful Matrix(水~)

Description

给出一个 55 的矩阵,只有1个1,其他全是0,每次操作可以交换任意两行两列,问至少要几次操作可以使得1位于矩阵的中心位置

Input

一个 55 的矩阵,只有1个1,其他全是0

Output

输出使得1位于矩阵的中心位置的最少操作数

Sample Input

0 0 0 0 0
0 0 0 0 1
0 0 0 0 0
0 0 0 0 0
0 0 0 0 0

Sample Output

3

Solution

水题, ans=abs(i3)+abs(j3),(i,j) 为1的位置

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int ans,a;
    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++)
        {
            scanf("%d",&a);
            if(a==1)ans=abs(i-3)+abs(j-3);
        }
    printf("%d\n",ans);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值