CodeForces 208 A.Dubstep(水~)

Description

给出一个字符串,两个单词之间会用若干个WUB分隔开,输出去掉WUB加好空格的字符串

Input

给出一个只由大写字母组成的字符串,串长不超过200

Output

输出处理后的字符串

Sample Input

WUBWEWUBAREWUBWUBTHEWUBCHAMPIONSWUBMYWUBFRIENDWUB

Sample Output

WE ARE THE CHAMPIONS MY FRIEND

Solution

水题,标记一下第一个单词是否出现来判断每次输出单词前是否需要空格,然后遇到WUB就跳过即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char s[maxn];
int main()
{
    while(~scanf("%s",s))
    {
        int n=strlen(s);
        int flag=0;
        for(int i=0;i<n;i++)
        {
            while(i+2<n&&s[i]=='W'&&s[i+1]=='U'&&s[i+2]=='B')i+=3;
            if(flag)printf(" ");
            while(i<n&&!(i+2<n&&s[i]=='W'&&s[i+1]=='U'&&s[i+2]=='B'))printf("%c",s[i]),i++;
            i--;
            flag=1;
        }
        printf("\n"); 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值