CodeForces 344 A.Magnets(水~)

Description

n 块磁铁排成一排,磁铁有两种状态,01和10分别表示正极的不同方向,问最后这些磁铁会变成几段

Input

第一行一整数n表示磁铁的个数,之后 n 行每行01或10表示该块磁铁的状态(1n100000)

Output

输出这些磁铁最后会分成多少段

Sample Input

6
10
10
10
01
10
10

Sample Output

3

Solution

水题,只要相邻两个磁铁的状态不用则段数加一

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int n,a[maxn];
int main()
{
    while(~scanf("%d",&n))
    {
        int num=1;
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        for(int i=2;i<=n;i++)if(a[i]!=a[i-1])num++;
        printf("%d\n",num);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值