Description
求
n
个节点构成的高度不小于
Input
两个整数 n,h(1≤h≤n≤35)
Output
输出
n
个节点构成的高度不小于
Sample Input
3 2
Sample Output
5
Solution
dp[n][h]
表示
n
个节点构成的高度为
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef unsigned long long ull;
typedef long long ll;
typedef pair<int,int>P;
const int maxn=40;
bool flag[maxn][maxn];
ull dp[maxn][maxn];
ull Solve(int n,int h)
{
if(flag[n][h])return dp[n][h];
flag[n][h]=1;
if(n==h)
{
if(n==0)return dp[n][h]=1;
return dp[n][h]=1ull<<(n-1);
}
if(((1ll<<h)-1<n)||n<h)return dp[n][h]=0;
ull ans=0;
for(int h1=0;h1<h;h1++)
for(int h2=0;h2<h;h2++)
if(max(h1,h2)==h-1)
for(int x=0;x<n;x++)
ans+=Solve(x,h1)*Solve(n-1-x,h2);
return dp[n][h]=ans;
}
int main()
{
int n,h;
while(~scanf("%d%d",&n,&h))
{
ull ans=0;
for(int i=h;i<=n;i++)ans+=Solve(n,i);
printf("%I64u\n",ans);
}
return 0;
}