Description
给出一张
n
个点
Input
第一行两个整数
n,m
,之后
m
行每行两个整数
Output
输出补图的三元环个数
Sample Input
5 5
1 2
1 3
2 3
2 4
3 4
Sample Output
3
Solution
考虑其补图被破坏的三元环个数,对于一点
v
,在原图的度为
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=1000005;
int n,m,du[maxn];
int main()
{
while(~scanf("%d%d",&n,&m))
{
memset(du,0,sizeof(du));
for(int i=1;i<=m;i++)
{
int u,v;
scanf("%d%d",&u,&v);
du[u]++,du[v]++;
}
ll ans=0;
for(int i=1;i<=n;i++)ans+=(ll)du[i]*(n-1-du[i]);
ans=(ll)n*(n-1)*(n-2)/6-ans/2;
printf("%I64d\n",ans);
}
return 0;
}