CodeForces 251 A.Points on Line(二分)

Description

给出数轴上 n 个点的坐标,问有多少种方案可以从中选取三个点使得其中距离最远点对距离不超过d

Input

第一行两个整数 n,d ,之后升序的输入 n 个点的坐标ai (1n105,1d109,|ai|109)

Output

输出满足条件的方案数

Sample Input

4 3
1 2 3 4

Sample Output

1

Solution

枚举第一个点,之后二分找到距其距离不超过 d 的点数cnt,从中任意取两个均可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int n,d,a[maxn];
ll C(int n)
{
    return (ll)n*(n-1)/2;
}
int main()
{
    while(~scanf("%d%d",&n,&d))
    {
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        ll ans=0;
        for(int i=0;i<n;i++)
        {
            int pos=upper_bound(a,a+n,a[i]+d)-a-1;
            ans+=C(pos-i);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值