CodeForces 374 B.Inna and Nine(组合数学)

Description

给出一个数字串,现在可以将相邻位置和为 9 的两个数字变成一个9,最终要使得串的 9 尽可能多,问可以变成多少种不同的串

Input

一个数字串a表示一个正整数 (1a10100000)

Output

输出答案,保证解不超过 2631

Sample Input

369727

Sample Output

2

Solution

对于连续的可以保证相邻两个位置和为 9 的一段,假设其长度是num,如果 num 为偶数,那么必然会变成 num2 9 ,方案唯一,如果num是奇数,那么至多可以变成 num12 9 ,剩一个数字的可能性有num+12,因为该数字只能在这 num 个数字的奇数位置,否则得不到最多的 9 <script type="math/tex" id="MathJax-Element-17">9</script>

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100005;
char s[maxn];
int main()
{
    while(~scanf("%s",s))
    {
        int n=strlen(s);
        ll ans=1;
        for(int i=0;i<n-1;i++)
        {
            if(s[i]-'0'+s[i+1]-'0'==9)
            {
                int num=1;
                while(i<n-1&&s[i]-'0'+s[i+1]-'0'==9)num++,i++;
            //  printf("num=%d\n",num);
                if(num&1)ans*=(ll)(num+1)/2;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值