GYM 100796 I.Shell Game(计算几何)

Description

给出一个圆台,上底面半径 r ,下底面半径R,高 h ,问该圆台内部可以放的最大球的半径

Input

三个整数r,R,h(1r<R104,1h104)

Output

输出该圆台内部可防止的最大球的半径,误差不超过 106

Sample Input

3 4 8

Sample Output

3.531128874149

Solution

求出该圆台所属的圆锥的内接球半径,与圆台高度的一半取最小值即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
const double PI=acos(-1.0);
int main()
{
    double r,R,h;
    while(~scanf("%lf%lf%lf",&r,&R,&h))
    {
        double h1=h*r/(R-r);
        h+=h1;
        double L=sqrt(R*R+h*h); 
        double x=min(h*R/(L+R),0.5*(h-h1));
        printf("%.10f\n",x);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值