GYM 100801 D.Distribution in Metagonia(数论+构造)

253 篇文章 2 订阅
201 篇文章 10 订阅

Description

给出一整数 n ,要求给n拆成若干个素因子只能是 2 3的数字之和,且这些数字不存在一个数字整除另一个数字的情况

Input

第一行一整数 T 表示用例组数,每组用例输入一整数n(1T1000,1n1018)

Output

对于每组用例,首先输出拆成数的个数 m(1m100) ,之后输出这 m 个数字

Sample Input

4
1
2
3
10

Sample Output

1
1
1
2
1
3
2
4 6

Solution

考虑将n拆成 n=2x3ya ,其中 2/|a,3/|a ,如果 a=1 那么问题就解决了,如果 a>1 则显然 a>4 a 是奇数,考虑不超过a 3 的最大幂次3z,即 3z<a<3z+1 ,令 b=a3z ,则 b 是偶数,将n拆成 n=2x3y+z+2x3yb ,由于 b<23z ,故 b 所能提供的3的幂次不会超过 z ,但b一定可以提供一个 2 的幂次,故只要重复上面的过程,每次2的幂次严格增, 3 <script type="math/tex" id="MathJax-Element-31">3</script>的幂次不增,必然满足不存在一个数字整除另一个数字的情况,且一定可以拆分

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=105;
int T,res;
ll n,ans[maxn];
void Solve(ll n,ll m)
{
    while(n%2==0)n/=2,m*=2;
    while(n%3==0)n/=3,m*=3;
    if(n==1)
    {
        ans[res++]=m;
        return ;
    }
    ll t=3;
    while(t*3<n)t*=3;
    ans[res++]=m*t;
    Solve(n-t,m);
}
int main()
{
    freopen("distribution.in","r",stdin);
    freopen("distribution.out","w",stdout);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d",&n);
        res=0;
        Solve(n,1);
        printf("%d\n",res);
        for(int i=0;i<res;i++)printf("%I64d%c",ans[i],i==res-1?'\n':' ');
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值