CodeForces 21 C.Stripe 2(水~)

Description

给出一个长度为 n n 的序列,要求把该序列分成非空的三部分,使得这三部分各自的和相同,问方案数

Input

第一行一整数n表示序列长度,之后输入 n n 个整数a1,...,an表示该序列 (1n105,|ai|104) ( 1 ≤ n ≤ 10 5 , | a i | ≤ 10 4 )

Output

输出方案数

Sample Input

4
1 2 3 3

Sample Output

1

Solution

对序列求一个前缀和 si=a1+...+ai s i = a 1 + . . . + a i ,如果 sn s n 不能被三整除显然无解,否则令 x=sn3 x = s n 3 ,令 numi n u m i 表示 s1,...,si s 1 , . . . , s i 中等于 x x 的前缀和个数,之后从后往前维护后缀和,即res=ai+...+an,如果 res=x r e s = x ,则说明 ai,...,an a i , . . . , a n 可以作为第三段,那么第一段就是 s1,...,si2 s 1 , . . . , s i − 2 中等于 x x 的前缀和个数,即numi2,累加入答案即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100005;
int n,a[maxn],s[maxn],num[maxn];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        s[i]=s[i-1]+a[i];
    }
    if(s[n]%3)printf("0\n");
    else
    {
        int x=s[n]/3;
        ll ans=0;
        for(int i=1;i<=n;i++)
            num[i]=num[i-1]+(s[i]==x);
        int res=0;
        for(int i=n;i>2;i--)
        {
            res+=a[i];
            if(res==x)ans+=num[i-2];
        }
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值