BJTUOJ 1856 奇怪的求和(数论)

11 篇文章 1 订阅

Description

定义 d(x) d ( x ) x x 的因子个数(包括她本身)。 如d(3)=2,因为 3 3 1和她本身,共两个因子。 定义 S(x)=i=1xd(i) S ( x ) = ∑ i = 1 x d ( i ) , 即从 1 1 x所有数字的因子个数之和。 现已知 x x ,求S(x)

Input

一个正整数 x(1x30000000) x ( 1 ≤ x ≤ 30000000 )

Output

S(x) S ( x ) 的值。

Sample Input

3

Sample Output

5

Solution

考虑 i i 是多少个数字的因子即得答案为i=1xxi,累加即得答案,时间复杂度 O(nlog2n) O ( n l o g 2 n )

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int n,ans=0;
    scanf("%d",&n);
    for(int i=1;i<=n;i++)ans+=n/i;
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值