GYM 101755 A.Restoring Numbers(数论)

201 篇文章 10 订阅

Description

已知两个正整数 a,b a , b 的和 s s 与最大公约数g,求 a,b a , b

Input

两个整数 s,g(1s,g109) s , g ( 1 ≤ s , g ≤ 10 9 )

Output

如果有满足条件的 a,b a , b 则输出任意一组,否则输出 1 − 1

Sample Input

6 2

Sample Output

4 2

Solution

a=cg,b=dg,(c,d)=1,s=a+b=(c+d)g a = c ⋅ g , b = d ⋅ g , ( c , d ) = 1 , s = a + b = ( c + d ) ⋅ g ,故若 g|s g | s s>g s > g a=g,b=sg a = g , b = s − g 显然符合条件,否则无解

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int s,g;
    while(~scanf("%d%d",&s,&g))
        if(s%g!=0||s==g)printf("-1\n");
        else printf("%d %d\n",g,s-g); 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值