GYM 101755 J.Parallelograms(水~)

253 篇文章 2 订阅

Description

给出 n n 个长度分别为a1,...,an的木棍,问这些木棍可以组成多少个平行四边形

Input

第一行一整数 n n 表示木棍数量,之后n个整数 a1,...,an a 1 , . . . , a n 表示木棍长度 (1n,ai2105) ( 1 ≤ n , a i ≤ 2 ⋅ 10 5 )

Output

输出最多可以构成的平行四边形数量

Sample Input

4
1 2 1 2

Sample Output

1

Solution

统计每个长度出现的次数 numi n u m i ,答案即为 numi22 ⌊ ∑ ⌊ n u m i 2 ⌋ 2 ⌋

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=200001;
int n,a[maxn];
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        int temp;
        scanf("%d",&temp);
        a[temp]++;
    }
    int ans=0;
    for(int i=1;i<=200000;i++)ans+=a[i]/2;
    printf("%d\n",ans/2);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值