ZOJ 4025 King of Karaoke(水~)

15 篇文章 0 订阅

Description

给出两个长度均为 n n 的序列a b b ,先可以给a序列每个元素加一个常数,问加完常数后这两个序列相同的位置数最大值

Input

第一行一整数 T T 表示用例组数,每组用例首先输入一整数n表示序列长度,之后输入 n n 个整数a1,...,an表示 a a 序列,最后输入n个整数 b1,...,bn b 1 , . . . , b n 表示 b b 序列

(1n105,105ai,bi105)

Output

对于每组用例,输出加完常数的 a a 序列和b序列相同位置数的最大值

Sample Input

2
4
1 2 3 4
2 3 4 6
5
-5 -4 -3 -2 -1
5 4 3 2 1

Sample Output

3
1

Solution

简单题, biai b i − a i 的众数即为答案

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100005;
int T,n,a[maxn],b[maxn];
map<int,int>M;
map<int,int>::iterator it;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)scanf("%d",&b[i]);
        M.clear();
        for(int i=1;i<=n;i++)M[a[i]-b[i]]++;
        int ans=0;
        for(it=M.begin();it!=M.end();it++)ans=max(ans,it->second);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值