ZOJ 4036 Lucky 7(水~)

15 篇文章 0 订阅

Description

给出 n n 个整数ai和一个整数 b b ,问是否存在ai+b 7 7 整除

Input

第一行一整数T表示用例组数,每组用例首先输入两个整数 n,b n , b ,之后输入 n n 个整数ai

(1n,ai,bi100) ( 1 ≤ n , a i , b i ≤ 100 )

Output

如果存在 ai a i 使得 ai+b a i + b 7 7 整除则输出Yes,否则输出 No N o

Sample Input

4
3 7
4 5 6
3 7
4 7 6
5 2
2 5 2 5 2
4 26
100 1 2 4

Sample Output

No
Yes
Yes
Yes

Solution

水题

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int T,n,a,b;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&b);
        int flag=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            if((a+b)%7==0)flag=1;
        }
        printf("%s\n",flag?"Yes":"No");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值