GYM 101653 M.Polyhedra Given(水~)

253 篇文章 2 订阅

Description

已知所有凸多面体的欧拉示性数 x=VE+F=2 x = V − E + F = 2 ,其中 V,E,F V , E , F 分别为顶点数、边数和面数,现在给出一个凸多面体的点数和边数,求面数

Input

第一行一整数 T T 表示用例组数,每组用例输出两个整数V,E表示一个凸多面体的点数和边数

(1T100,4V,E100) ( 1 ≤ T ≤ 100 , 4 ≤ V , E ≤ 100 )

Output

输出面数 F F

Sample Input

2
8 12
4 6

Sample Output

6
4

Solution

简单题,F=E+2V

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int main()
{
    int T,V,E,F;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&V,&E);
        F=E+2-V;
        printf("%d\n",F);
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值