hdu 1789 Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题意:大致意思是给出n个作业最后完成的日期和不交所需要扣除的分,你需要找到一种方案使扣的分数最少。

题解:可以看出这是一道贪心题,刚开始我直接按照日期排序,然后分数高的排在前面,发现并不是最优 ,所以改变一下思路 ,把扣分高的排在前面,分数相同的先结束的排在前面。做一门作业时,从截止日期到第一天遍历,如果哪一天有空闲,就把这门作业放在这一天,完成作业的时间越晚越好,如果没有一天空闲,那么就算不能完成。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int d,f;   //日期,分数
}q[1010];
int book[1010];
bool cmp(node a,node b)  //排序
{
    if(a.f!=b.f)    
        return a.f>b.f;
    return a.d<b.d;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(book,0,sizeof(book));
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&q[i].d);
        for(int i=0;i<n;i++)
            scanf("%d",&q[i].f);
        sort(q,q+n,cmp);
        int sum=0;
        int v;
        for(int i=0;i<n;i++)
        {
            v=q[i].d;   //找到截止日期
            while(v)    //开始从截止日期向第一天遍历
            {
                if(book[v]==0)   //这天有空闲
                {
                    book[v]=1;   //标记
                    break;
                }
                v--;
            }
            if(v==0)     //没有时间做这门作业
                sum+=q[i].f;    //加上该门作业扣的分数
        }
        printf("%d\n",sum);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值