5.13 词频统计 (30分)

词频统计

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:
输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:
在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:
This is a test.

The word “this” is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee. But this_8 is different than this, and this, and this…#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)
23
5:this
4:is

感谢武汉理工大学的郭小兵老师修正测试数据!

题目链接:https://pintia.cn/problem-sets/434/problems/6259

AC代码:

#include <map>
#include <cmath>
#include <stack>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;

struct node {
	string word;
	int count;
}arr[10010];

bool cmp(node a, node b)
{
	if (a.count == b.count) {
		return a.word < b.word;
	}

	return a.count > b.count;
}

int main() {

	string str;
	int num = 0;
	while (cin >> str) {
		string word = "";
		int i, k = 0, flag = 0;
		for (i = 0; i < str.size(); i++) {
			if ((str[i] >= '0'&&str[i] <= '9') || (str[i] >= 'a'&&str[i] <= 'z') ||(str[i] >= 'A'&&str[i] <= 'Z')|| str[i] == '_') {
				if (str[i] >= 'A'&&str[i] <= 'Z') {
					str[i] += 32;
				}
				word += str[i];
				k++;
			}
			else {
				if (str[i] == '#') {
					flag = 1;
					break;
				}

				int j, m = 1;
				for (j = 0; j < num; j++) {
					if (arr[j].word == word) {
						arr[j].count++;
						m = 0;
					}
				}
				if (m&&word != "") {
					arr[num].word = word;
					arr[num].count = 1;
					num++;
				}

				word = "";
				k = 0;
			}

			if (k == 15) {
				break;
			}
		}
		
		int j, m = 1;
		for (j = 0; j < num; j++) {
			if (arr[j].word == word) {
				arr[j].count++;
				m = 0;
			}
		}
		if (m&&word != "") {
			arr[num].word = word;
			arr[num].count = 1;
			num++;
		}
		
		if (flag) {
			break;
		}
	}

	sort(arr, arr + num, cmp);

	cout << num << endl;
	int i;
	for (i = 0; i < num / 10; i++) {
		cout << arr[i].count << ":" << arr[i].word << endl;
	}

	//system("pause");

	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Vcatory

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值