Description
In the new ACM-ICPC Regional Contest, a special monitoring and submitting system will be set up, and students will be able to compete at their own universities. However there’s one problem. Due to the high cost of the new judging system, the organizing committee can only afford to set the system up such that there will be only one way to transfer information from one university to another without passing the same university twice. The contestants will be divided into two connected regions, and the difference between the total numbers of students from two regions should be minimized. Can you help the juries to find the minimum difference?
Input
There are multiple test cases in the input file. Each test case starts with two integers N and M, (1 ≤ N ≤ 100000, 1 ≤ M ≤ 1000000), the number of universities and the number of direct communication line set up by the committee, respectively. Universities are numbered from 1 to N. The next line has Nintegers, the Kth integer is equal to the number of students in university numbered K. The number of students in any university does not exceed 100000000. Each of the following M lines has two integers s, t, and describes a communication line connecting university s and university t. All communication lines of this new system are bidirectional.
N = 0, M = 0 indicates the end of input and should not be processed by your program.
Output
For every test case, output one integer, the minimum absolute difference of students between two regions in the format as indicated in the sample output.
Sample Input
7 6 1 1 1 1 1 1 1 1 2 2 7 3 7 4 6 6 2 5 7 0 0
Sample Output
Case 1: 1
题目大意:给你一棵树,每个节点赋上权值值, 当去掉一条边后分成的两部分权值之和差的绝对值最小,求这个最小的绝对值。
准确来说算不上树形DP,仅仅用到树的结构了而已。
先以任意一点为根,向下DFS. 求出以每个子节点为根的向下的节点权值之和,这就求出其中一部分的权值,再用总权值相减便是另一部分的权值。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
long long abs(long long x)
{
return x>0?x:-x;
}
long long f[100010];//记录一该点为根节点的子树权值
int head[100010];
bool visit[100010];
int v[100010];
struct
{
int to;
int next;
}edge[200010];
int ip;
void addedge(int u,int v)
{
edge[ip].to=v;
edge[ip].next=head[u];
head[u]=ip++;
}
void dfs(int x)//求以X点为根节点的子树的权值之和
{int p;
visit[x]=1;
p=head[x];
while(p!=-1)
{
if(!visit[edge[p].to])
{
dfs(edge[p].to);
f[x]+=f[edge[p].to];
}
p=edge[p].next;
}
f[x]+=v[x];
}
int main()
{int n,m,x,y;
int case1=1;
long long ans,temp;
while(cin>>n>>m&&n+m)
{memset(f,0,sizeof(f));
memset(head,-1,sizeof(head));
memset(visit,0,sizeof(visit));
memset(edge,-1,sizeof(edge));
ip=0;
for(int i=1;i<=n;i++)
scanf("%d",&v[i]);
for(int i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
addedge(x,y);
addedge(y,x);
}
dfs(1);
ans=1e18;
for(int i=1;i<=n;i++)
{
temp=abs(f[1]-(f[i]<<1));
ans=min(ans,temp);
}
printf("Case %d: %lld\n",case1++,ans);
}
return 0;
}