FatMouse's Speed
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20 Accepted Submission(s) : 11
Special Judge
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file. The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that W[m[1]] < W[m[2]] < ... < W[m[n]] and S[m[1]] > S[m[2]] > ... > S[m[n]] In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
Source
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20 Accepted Submission(s) : 11
Special Judge
Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file. The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. Two mice may have the same weight, the same speed, or even the same weight and speed.
Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that W[m[1]] < W[m[2]] < ... < W[m[n]] and S[m[1]] > S[m[2]] > ... > S[m[n]] In order for the answer to be correct, n should be as large as possible. All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
Sample Output
4
4
5
9
7
Source
Zhejiang University Training Contest 2001
#include<algorithm>
#include<cmath>
#include<ctime>
#include<string>
#include<stack>
#include<deque>
#include<queue>
#include<list>
#include<set>
#include<map>
#include<cstdio>
#define mes(x) memset(x, 0, sizeof(x))
typedef long long ll;
#define Pii pair<int, int>
#define Pll pair<ll, ll>
#define INF 1<<31
using namespace std;
const int MAX = 5000;
#define MOD 10000000
int main()
{
//freopen("/home/ostreambaba/文档/input.txt", "r", stdin);
//freopen("/home/ostreambaba/文档/output.txt", "w", stdout);
pair<int, pair<int, int> >mouse[1001];
int n = 0;
int weight, speed;
while(cin >> weight >> speed)
{
mouse[n].first = weight;
mouse[n].second.second = n+1;
mouse[n++].second.first = speed;
}
sort(mouse, mouse+n);
int *dp = new int[n];
int Max = 0;
int *index = new int[n]();
int *maxindex = new int[n](); //记录最大长度的序列
int Max_last; //记录最大序列的最后一个下标
for(int i = 0; i < n; ++i) //最长单调递增子序列的做法加了一个记录最长的子序列
{
dp[i] = 1;
for(int j = 0; j < i; ++j)
if(mouse[i].second.first<mouse[j].second.first&&mouse[i].first>mouse[j].first&&dp[i]<dp[j]+1)
{
dp[i] = dp[j]+1;
index[i] = j; // 记录最子序列老鼠前面的老鼠的下标
if(dp[i] > Max)
{
Max = dp[i];
Max_last = i; / //记录最长子序列最后一只老鼠的下标
}
}
}
cout << Max << endl;
int t = Max;
int temp = Max_last;
int i = 0;
while(t--) //此处需逆推
{
maxindex[i++] = temp;
temp = index[temp];
}
for(int i = Max-1; i >= 0; --i) //输出真正的最原始的下标
{
cout << mouse[maxindex[i]].second.second << endl;
}
delete [] dp;
delete [] index;
delete [] maxindex;
return 0;
}