poj 1308 Is It A Tree?(并查集)

Is It A Tree?
Time Limit: 1000MS      Memory Limit: 10000K
Total Submissions: 31698        Accepted: 10765
Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
判断给出的边所组成的是不是一棵树。
用并差集即可。
特别注意的是空树也是一棵树。
即输入0 0,这也是一棵树。
用vis记录输入的点。
判断所有子节点是否是汇聚与一个节点即可。
即记录rt是否等于1.
还是就是:出现环路不是树,出现森林也不是树。
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cctype>
#include<cmath>
#include<ctime>
#include<string>
#include<stack>
#include<deque>
#include<queue>
#include<list>
#include<set>
#include<map>
#include<cstdio>
#include<limits.h>
#define MOD 1000000007
#define fir first
#define sec second
#define fin freopen("/home/ostreambaba/文档/input.txt", "r", stdin)
#define fout freopen("/home/ostreambaba/文档/output.txt", "w", stdout)
#define mes(x, m) memset(x, m, sizeof(x))
#define Pii pair<int, int>
#define Pll pair<ll, ll>
#define INF 1e9+7
#define inf 0x3f3f3f3f
#define Pi 4.0*atan(1.0)

#define lowbit(x) (x&(-x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define max(a,b) a>b?a:b

typedef long long ll;
typedef unsigned long long ull;
const double eps = 1e-9;
const int maxn = 1000+5;
const int maxm = 10000005;
using namespace std;

inline int read(){
    int x(0),f(1);
    char ch=getchar();
    while (ch<'0'||ch>'9') {if (ch=='-') f=-1;ch=getchar();}
    while (ch>='0'&&ch<='9') x=x*10+ch-'0',ch=getchar();
    return x*f;
}
int p[maxn];
bool vis[maxn];
void init(){
    mes(vis,false);
    for(int i=1;i<=maxn;++i){
        p[i]=i;
    }
}
inline int find(int x){
    return x==p[x]?x:p[x]=find(p[x]);
}
inline void merge(int x,int y){
    x=find(x),y=find(y);
    if(x!=y){
        p[y]=x;
        vis[y]=vis[x]=true;
    }
}
int main(){
  //  fin;
    int x,y;
    int cnt=1;
    while(~scanf("%d%d",&x,&y)){
        if(x==-1&&y==-1){
            break;
        }
        if(!x&&!y){
            printf("Case %d is a tree.\n",cnt++);
            continue;
        }
        init();
        merge(x,y);
        bool flag=true;
        while(~scanf("%d%d",&x,&y)&&(x||y)){
            if(find(x)==find(y)){ //判断是否会出现环
                flag=false;
            }
            merge(x,y);
        }
        if(!flag){
            printf("Case %d is not a tree.\n",cnt++);
        }else{
            int rc=0;
            for(int i=1;i<=maxn;++i){ //判断是否会出现森林
                if(vis[i]&&i==p[i]){
                    ++rc;
                }
            }
            if(rc==1){ //点为1则说明只有一棵树
                printf("Case %d is a tree.\n",cnt++);
            }else{
                printf("Case %d is not a tree.\n",cnt++);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值