George and Accommodation
Time limit 1000 ms
Memory limit 262144 kB
Problem Description
George has recently entered the BSUCP (Berland State University for Cool Programmers). George has a friend Alex who has also entered the university. Now they are moving into a dormitory.
George and Alex want to live in the same room. The dormitory has n rooms in total. At the moment the i-th room has pi people living in it and the room can accommodate qi people in total (pi ≤ qi). Your task is to count how many rooms has free place for both George and Alex.
Input
The first line contains a single integer n (1 ≤ n ≤ 100) — the number of rooms.
The i-th of the next n lines contains two integers pi and qi (0 ≤ pi ≤ qi ≤ 100) — the number of people who already live in the i-th room and the room’s capacity.
Output
Print a single integer — the number of rooms where George and Alex can move in.
Sample Input
3
1 10
0 10
10 10
Sample Output
2
Source Problem Link:
https://vjudge.net/problem/CodeForces-467A
解题代码:
#include <iostream>
using namespace std;
int main(void)
{
int n, count, now, max;
int i;
count = 0;
cin >> n;
if(n >= 1 && n <= 100)
{
for(i = 0; i < n; i++)
{
cin >> now >> max;
if(now <= max && now >= 0 && max >= 0 && now <= 100 && max <= 100)
{
if(max - now >= 2)
{
count++;
}
}
else
{
break;
}
}
}
cout << count;
return 0;
}