第一期练习题 - 第二题

George and Accommodation

Time limit 1000 ms
Memory limit 262144 kB

Problem Description

George has recently entered the BSUCP (Berland State University for Cool Programmers). George has a friend Alex who has also entered the university. Now they are moving into a dormitory.
George and Alex want to live in the same room. The dormitory has n rooms in total. At the moment the i-th room has pi people living in it and the room can accommodate qi people in total (pi ≤ qi). Your task is to count how many rooms has free place for both George and Alex.

Input

The first line contains a single integer n (1 ≤ n ≤ 100) — the number of rooms.
The i-th of the next n lines contains two integers pi and qi (0 ≤ pi ≤ qi ≤ 100) — the number of people who already live in the i-th room and the room’s capacity.

Output

Print a single integer — the number of rooms where George and Alex can move in.

Sample Input

3
1 10
0 10
10 10

Sample Output

2

Source Problem Link:

https://vjudge.net/problem/CodeForces-467A

解题代码:

#include <iostream>

using namespace std;

int main(void)
{
	int n, count, now, max;
	int i;

	count = 0;

	cin >> n;
	if(n >= 1 && n <= 100)
	{
		for(i = 0; i < n; i++)
		{
			cin >> now >> max;
			if(now <= max && now >= 0 && max >= 0 && now <= 100 && max <= 100)
			{
				if(max - now >= 2)
				{
					count++;
				}
			}
			else
			{
				break;
			}
		}
	}

	cout << count;

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值