A1136. Delayed Palindrome

Consider a positive integer N written in standard notation with k+1 digits ai​​ as ak​​a1​​a0​​ with 0 for all i and ak​​>0. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.


#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
typedef struct NODE{
    int num[1010], len;
    NODE(){
        fill(num, num + 1010, 0);
        len = 0;
    }
}bign;
void add(bign &a, bign &b, bign &c){
    c.len = 0;
    b.len = 0;
    for(int i = a.len - 1; i >= 0; i--){
        b.num[b.len++] = a.num[i]; 
    }
    int carry = 0;
    int i;
    for(i = 0; i < b.len && i < a.len; i++){
        int sum = a.num[i] + b.num[i] + carry;
        carry = sum / 10;
        c.num[c.len++] = sum % 10;
    }
    while(i < b.len){
        int sum = carry + b.num[i];
        c.num[c.len++] = sum % 10;
        carry = sum / 10;
    }
    while(i < a.len){
        int sum = carry + a.num[i];
        c.num[c.len++] = sum % 10;
        carry = sum / 10;
    }
    if(carry != 0){
        c.num[c.len++] = carry;
    }
}
int isReverse(bign a){
    for(int i = 0, j = a.len - 1; i <= j; i++, j--){
        if(a.num[i] != a.num[j])
            return 0;
    }
    return 1;
}
int main(){
    char ss[1000];
    scanf("%s", ss);
    bign a, b, c;
    for(int i = strlen(ss) - 1; i >= 0; i--){
        a.num[a.len++] = ss[i] - '0';
    }
    int tag = 0;
    if(isReverse(a)){
        for(int i = a.len - 1; i >= 0; i--){
            printf("%d", a.num[i]);
        }
        printf(" is a palindromic number.");
        return 0;
    }
    for(int i = 0; i < 10; i++){
        add(a,b,c);
        for(int k = a.len - 1; k >= 0; k--){
            printf("%d", a.num[k]);
        }
        printf(" + ");
        for(int k = b.len - 1; k >= 0; k--){
            printf("%d", b.num[k]);
        }
        printf(" = ");
        for(int k = c.len - 1; k >= 0; k--){
            printf("%d", c.num[k]);
        }
        printf("\n");
        if(isReverse(c)){
            tag = 1;
            for(int j = c.len - 1; j >= 0; j--){
                printf("%d", c.num[j]);
            }
            printf(" is a palindromic number.");
            break;
        }else{
            for(int k = 0; k < c.len; k++){
                a.num[k] = c.num[k];
            }
            a.len = c.len;
        }
    }
    if(tag == 0){
        printf("Not found in 10 iterations.\n");
    }
    cin >> ss;
    return 0;
}
View Code

总结:

1、大整数相加的问题。要注意的是,在a+b做完之后,要注意检查carry是否为0,如果不为0的话,需要再把carry加上。

2、1230的相反是0123而不是123,所以本题相当于两个待加的数字位数都相同,所以可以直接用两个string做加法,比使用大整数模拟要快一些。

转载于:https://www.cnblogs.com/zhuqiwei-blog/p/9560088.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
4S店客户管理小程序-毕业设计,基于微信小程序+SSM+MySql开发,源码+数据库+论文答辩+毕业论文+视频演示 社会的发展和科学技术的进步,互联网技术越来越受欢迎。手机也逐渐受到广大人民群众的喜爱,也逐渐进入了每个用户的使用。手机具有便利性,速度快,效率高,成本低等优点。 因此,构建符合自己要求的操作系统是非常有意义的。 本文从管理员、用户的功能要求出发,4S店客户管理系统中的功能模块主要是实现管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理,用户客户端:首页、车展、新闻头条、我的。门店客户端:首页、车展、新闻头条、我的经过认真细致的研究,精心准备和规划,最后测试成功,系统可以正常使用。分析功能调整与4S店客户管理系统实现的实际需求相结合,讨论了微信开发者技术与后台结合java语言和MySQL数据库开发4S店客户管理系统的使用。 关键字:4S店客户管理系统小程序 微信开发者 Java技术 MySQL数据库 软件的功能: 1、开发实现4S店客户管理系统的整个系统程序; 2、管理员服务端;首页、个人中心、用户管理、门店管理、车展管理、汽车品牌管理、新闻头条管理、预约试驾管理、我的收藏管理、系统管理等。 3、用户客户端:首页、车展、新闻头条、我的 4、门店客户端:首页、车展、新闻头条、我的等相应操作; 5、基础数据管理:实现系统基本信息的添加、修改及删除等操作,并且根据需求进行交流信息的查看及回复相应操作。
现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本微信小程序医院挂号预约系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此微信小程序医院挂号预约系统利用当下成熟完善的SSM框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。微信小程序医院挂号预约系统有管理员,用户两个角色。管理员功能有个人中心,用户管理,医生信息管理,医院信息管理,科室信息管理,预约信息管理,预约取消管理,留言板,系统管理。微信小程序用户可以注册登录,查看医院信息,查看医生信息,查看公告资讯,在科室信息里面进行预约,也可以取消预约。微信小程序医院挂号预约系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值