UVA - 10305(拓扑排序)

https://vjudge.net/problem/UVA-10305

题目:

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3

题目思路:

有很多任务 但是有些任务有先后顺序 要求输出做任务的顺序

显然用拓扑排序

AC代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <vector>
using namespace std;
const int maxn = 0X3f3f3f3f ;

int main()
{
//    freopen("in.txt","r",stdin);
    int n,m,parent[105];
    vector <int> child[105];
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        if(n==0 && m==0)break;
        int a,b;
        for(int i=0 ; i<n ; i++)
            child[i].clear();
        memset(parent,0,sizeof(parent));
        for(int i=0 ; i<m ; i++)
        {
            scanf("%d %d",&a,&b);
            child[a].push_back(b);
            parent[b]++;
        }

        for(int i=1 ; i<=n ; i++)
        {
            for(int j=1 ; j<=n ; j++)
            {
                if(parent[j]==0)
                {
                    if(i==1)printf("%d",j);
                    else printf(" %d",j);
                    for(int k=0 ; k<child[j].size() ; k++)
                        parent[child[j][k]]--;
                    child[j].clear();
                    parent[j]=maxn;
                    break;
                }
            }
        }
        printf("\n");
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值