POJ - 3026(BFS+最小生成树.krustal)

11 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3026

题目:

Borg Maze

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17462 Accepted: 5631

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11

题目思路:

其实s 和 a是一样的 只要求出连接A和S的最小生成树就可以了 

主要就是求每个点之间的距离就可以了  

具体求法用 BFS遍历每一个点  用邻接表储存  用kruskal算法求最小生成树就可以了

比较坑的就是 

一 题目样例里有莫名其妙的一串空格  在输入x y后有一大串空格  要读入并舍弃

二 数组要开大 n<50  我开55 就wa 开205就ac 。。。 迷。。。

AC代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;
char pic[205][205];
int alien[205][205],allroad,vis[205][205],t,n,m,num,father[205],sum;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
struct r
{
    int a,b,dis;
}road[100000];
struct node
{
    int x,y,step;
};
bool cmp(struct r a,struct r b)
{
    return a.dis<=b.dis;
}
void bfs(int bx,int by)
{
    memset(vis,0,sizeof(vis));
    queue <node> q;
    while(!q.empty())q.pop();
    node b,now,next;
    b.x=bx,b.y=by,b.step=0;
    vis[bx][by]=1;
    q.push(b);
    int c=0;
    while(!q.empty())
    {
        now = q.front();
        q.pop();
        if(vis[now.x][now.y]==0 && alien[now.x][now.y]>alien[bx][by])
        {
            c++;allroad++;
            road[allroad].a=alien[bx][by];
            road[allroad].b=alien[now.x][now.y];
            road[allroad].dis=now.step;
            if(c==num-1)break;
        }
        for(int d=0;d<4;d++)
        {
            next = now;
            next.x += dx[d];
            next.y += dy[d];
            if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;
            if(vis[next.x][next.y]==1 || pic[next.x][next.y]=='#')continue;
            next.step++;
            vis[next.x][next.y]=1;
            if(alien[next.x][next.y]>alien[bx][by])
            {
                c++;allroad++;
                road[allroad].a=alien[bx][by];
                road[allroad].b=alien[next.x][next.y];
                road[allroad].dis=next.step;
                if(c==num-1)break;
            }
            q.push(next);
        }
        if(c==num-1)break;
    }
}
int findd(int x);
int main()
{
    char temp[110];
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        scanf("%d %d",&m,&n);
        gets(temp);
        memset(alien,0,sizeof(alien));
        num=0;
        for(int i=0; i<n; i++)
        {
            cin.getline(pic[i],m+1);
            for(int j=0; j<m; j++)
                if(pic[i][j]=='A' || pic[i][j]=='S')
                {
                    num++;
                    alien[i][j]=num;
                }
        }
        allroad=-1;
        int flag=0;
        int c=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                {
                    if(alien[i][j]>0)
                    {
                        bfs(i,j);
                        c++;
                    }
                    if(c==num-1){flag=1;break;}
                }
            if(flag == 1)break;
        }
        sort(road,road+allroad+1,cmp);
        for(int i=1;i<=num;i++)
            father[i]=i;
        c=0;
        sum=0;
        for(int i=0;i<=allroad;i++)
        {
            int ha = findd(road[i].a);
            int hb = findd(road[i].b);
            if(ha != hb)
            {
                c++;
                father[ha]=hb;
                sum += road[i].dis;
                if(c == num-1)break;
            }
        }
        printf("%d\n",sum);

    }
    return 0;
}
int findd(int x)
{
    int a=x;
    while(father[x]!=x)
        x=father[x];
    while(x!=father[x])
    {
        int z=a;
        a=father[a];
        father[z]=x;
    }
    return x;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值