【POJ 1328】Radar Installation

34 篇文章 0 订阅
24 篇文章 0 订阅

Radar Installation

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1

题意:雷达只能放在x轴上,给出雷达半径,和岛屿坐标,问至少按多少个雷达可以覆盖全岛:

解题思路:根据岛屿到x轴的距离和半径r求出在x上的一个区间,区间内雷达都能扫到该岛公式:
左区间=x-sqrt(r*r-y*y):
右区间=x+sqrt(r*r-y*y):
按照右区间从小到大排序
要考虑 y>d 和d<0的情况
详细看AC代码 :

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node{
    double a,b;
}st[1000+11];
bool cmp(node i,node j)
{
    return i.a<j.a;
}
int main()
{
    int n,i,k=0;
    double x,y,d;
    bool flag;
    while(scanf("%d%lf",&n,&d)!=EOF&&(n||d))
    {
        k++;
        flag=false;
        for(i=0;i<n;i++)
        {
        scanf("%lf%lf",&x,&y);
        if(y>d||d<0) 
        flag=true;
        st[i].a=x-sqrt(d*d-y*y);
        st[i].b=x+sqrt(d*d-y*y);
        } 
        if(flag)
        {
            printf("Case %d: -1\n",k);
            continue;
        }
        sort(st,st+n,cmp);
        double max=st[0].b;int sum=1;;
        for(i=1;i<n;i++)
        {
        if(st[i].b<=max) 
        {
        max=st[i].b;
        }
        else if(st[i].a>max)
            {
                sum++;
                max=st[i].b;
            }
        }
        printf("Case %d: %d\n",k,sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值